Pitaya bricked during first programming attempt

I received my Pitaya today and it worked with the default firmware. However when I tried to upload the Bluetooth Low Energy app from RFConnect Desktop it started ok but then showed error during programming and now the device is bricked. I cannot enter DFU mode (user + reset). On power on only one green light is on.
Please help

Here are the logs:
2020-05-09T18:30:11.229Z INFO Application data folder: C:\Users\rod_d\AppData\Roaming\nrfconnect\pc-nrfconnect-ble
2020-05-09T18:30:11.349Z DEBUG App pc-nrfconnect-ble v2.3.2 official
2020-05-09T18:30:11.349Z DEBUG App path: C:\Users\rod_d.nrfconnect-apps\node_modules\pc-nrfconnect-ble
2020-05-09T18:30:11.349Z DEBUG nRFConnect 3.3.3 is supported by the app (^3.2.0)
2020-05-09T18:30:11.349Z DEBUG nRFConnect path: C:\Users\rod_d\AppData\Local\Programs\nrfconnect\resources\app.asar
2020-05-09T18:30:11.349Z DEBUG HomeDir: C:\Users\rod_d
2020-05-09T18:30:11.349Z DEBUG TmpDir: C:\Users\rod_d\AppData\Local\Temp
2020-05-09T18:30:18.282Z INFO Validating connectivity firmware for device with serial number F15321796114…
2020-05-09T18:30:52.845Z ERROR Error while setting up device F15321796114: Timeout while waiting for device F15321796114 to be attached and enumerated
2020-05-09T18:30:52.850Z INFO Device closed.