nRF52840-MDK IoT Development Kit and circuitpython

tried to flash circuitpython in order to use this board for my keyboard but it doesn’t work,
tired to use supplied HEX file from adafruit, and noting (no drive, and no serial com using DAPlink)
tired to build my own as instructed in adafruit git and still the same results (other HEX examples works for the boards) (also i am on version 054 DAPlink)
can any one help ?

Hi,
We will release the circuitpython firmware for nRF52840-MDK soon. Pls stay tuned for our updates!

I just build circuitpython 6.0.0 for nRF52840-MDK and it works. Here is the steps:

$ git clone https://github.com/adafruit/circuitpython.git
$ cd circuitpython
$ git submodule update --init
$ make -C mpy-cross
$ cd ports/nrf
$ make BOARD=makerdiary_nrf52840_mdk SD=s140 V=1

This should produce a build-makerdiary_nrf52840_mdk-s140/firmware.hex file.

You should merge the nRF52 Radio SoftDevice and firmware.hex:

$ cd build-makerdiary_nrf52840_mdk-s140
$ mergehex -m firmware.hex ../bluetooth/s140_nrf52_6.1.0/s140_nrf52_6.1.0_softdevice.hex -o circuitpython_6_0_0-alpha.3-99-g540e6d428_with_s140.hex

Then flash the final firmware:

$ pyocd flash -t nrf52840  circuitpython_6_0_0-alpha.3-99-g540e6d428_with_s140.hex

Open the serial port of nRF52840, you will see the REPL:

Here is the pre-built firmware. You can have a try!

is it normal thet it takes a minute plus to load ?
and do you know how i get access to built in CircuitPython drive ? (it shows as a non existing drive)
image