Getting Started Issue


#1

Hi, I’ve been trying to work through the wiki tutorials to get writing my own code but I’m having some trouble. This is my first attempt with anything trickier than an Arduino.

I have the nRF52840-MDK and I’m using 64bit windows 7.

I’m stuck at the https://wiki.makerdiary.com/nrf52840-mdk/nrf5-sdk/ section where you need to “make flash” the blinky program. I get an error telling me to configure the Makefie.windows file to suit my system, can anyone advise on the correct path?

C:\Users\Oisin\Documents\NRF Files\nrf52840-mdk-master\examples\nrf5-sdk\blinky\

armgcc>make flash
process_begin: CreateProcess(NULL, “C:\Program Files (x86)\GNU Tools Arm Embedde
d\6 2017-q2-update\binarm-none-eabi-gcc” --version, …) failed.
make: …/…/…/…/nrf_sdks/nRF5_SDK_15.0.0_a53641a/components/toolchain/gcc/Make
file.common:129: pipe: No error
Cannot find: ‘C:\Program Files (x86)\GNU Tools Arm Embedded\6 2017-q2-update\bin
arm-none-eabi-gcc’.
Please set values in: “C:/Users/Oisin/Documents/NRF Files/nrf52840-mdk-master/nr
f_sdks/nRF5_SDK_15.0.0_a53641a/components/toolchain/gcc/Makefile.windows”
according to the actual configuration of your system.
…/…/…/…/nrf_sdks/nRF5_SDK_15.0.0_a53641a/components/toolchain/gcc/Makefile.c
ommon:129: *** Cannot continue. Stop.


#2

Hi there,
First, pls make sure you have installed the GNU Arm Embedded Toolchain: 6-2017-q2-update. According to your system, you can download here directly: gcc-arm-none-eabi-6-2017-q2-update-win32-sha2.exe.

Then configure the toolchain path in C:/Users/Oisin/Documents/NRF Files/nrf52840-mdk-master/nr f_sdks/nRF5_SDK_15.0.0_a53641a/components/toolchain/gcc/Makefile.windows with the following settings:

GNU_INSTALL_ROOT := C:/Program Files (x86)/GNU Tools ARM Embedded/6 2017-q2-update/bin/
GNU_VERSION := 6.3.1
GNU_PREFIX := arm-none-eabi

BTW, make sure that make tool works well. Just follow the step to install MSYS2 and the tools: https://wiki.makerdiary.com/nrf52840-mdk/nrf5-sdk/#installing-gnu-make

Now you can try to compile the blinky example again in MSYS2 bash. Everything should work as expected.
Pls let me know if you have any concerns.

Zelin


#3

Thanks, that worked for me. I reinstalled the GNU toolchain and set the paths as you had suggested. Maybe I donwloaded the wrong GNU toolchain the first time.


#4

Good job. :+1: