DAPLink for nRF5832-MDK


#1

Recently i purchased nRF52832-MDK V2 IoT Micro Development Kit - Seeed Studio.
But I was unable to compile and debug the kit using CMSIS-DAP DEBUGGER, please provide KEIL IDE setting process for debugging the board.

Thank you


#2

Hi there,
You can follow these steps to use with Keil IDE:

  1. Connect the dev board to the PC. In KEIL uVision, click on the “Options for Target…” button.
    options_for_target

  2. A new window should open. Go to the Debug tab and select CMSIS-DAP Debugger from the drop-down menu, as in the following picture. Then click on the Settings button.
    select_debugger

  3. In the next windows select the CMSIS-DAP device. Set the SW port.
    debugger_settings

That’s it! If you still have any question, feel free to feedback here!

Best


#3

Hi,

  1. I connected development board to PC and I selected options for CMSIS_DAP debugger and all settings which you have provided.

    .

  2. Then after I tried to download code to flash memory, its showing popup error message as "flash download failed - Cortex M4".

    .

  3. Please provide solution for above error message and also provide user guide documentation about how to build DAPLINK for KEIL IDE for windows-7 &10, 64 bit PC.

Thanking you…


#4

Firstly, remember to configure the flash tool, as in the following picture:

Secondly, when the nRF52 flash has softdevice, downloading the application will happen this problem: Flash download failed - “Cortex-M4”. So, you need to erase all the nRF52 flash by using pyocd:

pyocd-flashtool -t nrf52 -ce

Follow this section to use pyocd: https://wiki.makerdiary.com/nrf52832-mdk/getting-started/#using-pyocd

It works after implementing the above steps:
flash_result

Thanks for your feedback!


#5

Hi,

Thank you very much, Programming successfully completed after configure the flash tool.

Thanks for your support.!


#6

:+1:


#7

Hi

After programming flash, when i entered into Start/Stop debug session button, debug options( Step, Step over, Step out, Run) are not highlighted as shown in the figure. Please suggest.

Thank you.


#8

hi,
I am using the blinky example and it works well:


As this post mentioned:
You can not do step by step debugging while having the SoftDevice active. This is due to the way the SoftDevice is implemented.
What you need to do is to insert a breakpoint where you want to check stuff, and then run up to that point.


#9

Hi,
Thank you very much for your valuable reply.

I did like as you told, inserted breakpoint where i want to check, but debug options are still not appeared as shown in below image.

Please resolve my issue.


#10

And i also found that , even though** flash load is finished** message appeared in Keil IDE, but hex file is not updating. Its always running the code that which is I previously loaded (Blinky Program) into kit using Drag and Drop method.

Please suggest me.

Thank you…!


#11

Hi,
Have you erased the chip using the following command?

pyocd-flashtool -t nrf52 -ce

The blinky example does not need Softdevice. So you can erase the chip and have a try again.

Thanks


#12

Hi sir,
I didn’t erased chip using that command, i will try for sure.

Sir, could you please send me link to download of nRF5_sdk_15.0.0_a53a file.

Thank you.


#13

15.2.0 is recommanded. I have double checked that you will resolve this issue after erasing the chip. BTW,remember to use the blank project file if no Softdevice used.


#14

Hi sir, with 15.2.0 sdk folder, flash programming done through blank project file, now debug options are enabled. Now i will try to program the simple blinky program for nRF52832-MDK V2 IoT Micro Development Kit.

Thank you very very much.!


#15

Congratulations! :tada: